Перейти к содержимому



Фотография
- - - - -

LED LG 22LV2300 (main L*01S) перезагружается на заставке

L*01S NAND Debug 22LV2300 Перезагружается

  • Закрытая тема Тема закрыта
Сообщений в теме: 10

#1 Евгений

Евгений

    Участник

  • Участники
  • Репутация
    10
  • 34 сообщений
  • Цель регистрации:
    Поиск информации
  • Род занятий:
    студент
  • Программатор:
    Тритон, CH341A
  • Осциллограф:
    Leader 8103

Отправлено 22 Июль 2015 - 09:32

Состав:
модель LG 22LV2300
шасси L*01S, EAX63979503(0)
Тюнер: EBL60721201 TDTJ-S001D
Звук: NTP-7100
SPI: IC1401 25Q80BVSIG
EEPROM: IC103 24C08 
ПАНЕЛЬ: M215HGE -L10 rec.C1
Блок питания = 24VDC внешний 
 
Приключилась такая же беда, как в теме letunov45 - перезагружается на заставке LG. Подозрение на слёт файловой системы в NAND
Подключился по 232, считал логи

Spoiler

 

Вот что выдало MTD Info

Spoiler

 

При попытке включения USB командой usb start выдает ошибку:

usb init failed
Error, couldn't init Lowlevel part
 

По терминалу через swuz прошивку заливает, однако как и писал letunov45 - по окончании заливки выдает надпись Dev mode: Debug Mode и не реагирует на терминал. Ждал 4 часа, безрезультатно. Обновления прошивки не происходит, после выключения и включения цикл перезагрузки повторяется, логи те же.

 

Пока идей нету, изучаю help команд.

З.Ы. Может, у кого-нибудь есть дамп нанды с L*01S?


  • 0



#2 LiVan

LiVan

    Вебмастер

  • Administrators
  • Репутация
    0
  • 1 805 сообщений
  • Цель регистрации:
    Участие в работе форума
  • Род занятий:
    Вебмастер
  • Программатор:
    RT809F, EZP2010, POSTAL3
  • Осциллограф:
    C1-65, C1-83

Отправлено 22 Июль 2015 - 10:54

LG 22LV2500/250A/250N/250U, CHASSIS : LD01S
Последние обновленные 22 Июл 2015 12:45



#3 Anatos

Anatos

    Мастер

  • Модераторы
  • Репутация
    90
  • 220 сообщений
  • Цель регистрации:
    Участие в работе форума
  • Род занятий:
    Технорук
  • Программатор:
    RT809F
  • Осциллограф:
    С1-65А

Отправлено 22 Июль 2015 - 10:55

При попытке включения USB командой usb start выдает ошибку: usb init failed Error, couldn't init Lowlevel part

 

судя по этой записи - [ 0.145000] usbcore: registered new device driver usb устройство работает нормально, просто не попал 

в u-boot. А строчка LM1 # , появляется, я что-то в логе не обнаружил.


  • 0

#4 Евгений

Евгений

    Участник

  • Участники
  • Репутация
    10
  • 34 сообщений
  • Цель регистрации:
    Поиск информации
  • Род занятий:
    студент
  • Программатор:
    Тритон, CH341A
  • Осциллограф:
    Leader 8103

Отправлено 22 Июль 2015 - 11:15

Anatos,  у меня после замыкания eeprom выдало saturn7 #, я ввел  debug debug и стал заходить сюда уже без замыкания, через Enter.

Это разве не u-boot?

 

Mig31, мануал уже читаю, спасибо


  • 0

#5 Anatos

Anatos

    Мастер

  • Модераторы
  • Репутация
    90
  • 220 сообщений
  • Цель регистрации:
    Участие в работе форума
  • Род занятий:
    Технорук
  • Программатор:
    RT809F
  • Осциллограф:
    С1-65А

Отправлено 22 Июль 2015 - 11:51

у меня после замыкания eeprom выдало saturn7 #,

да, это и есть u-boot , просто в логе этого не было прописано, вот и решил уточнить. 

Что б правильно сохранить лог, нужно при запуске в терминале выбрать функцию - Копировать всё в буфер - за тем, открываем блокнот и там сохраняем. 

Прикрепленный файл  буфер.jpg   53,01К   Количество загрузок: 0

тогда и вопросов лишних не будет....


  • 0

#6 Евгений

Евгений

    Участник

  • Участники
  • Репутация
    10
  • 34 сообщений
  • Цель регистрации:
    Поиск информации
  • Род занятий:
    студент
  • Программатор:
    Тритон, CH341A
  • Осциллограф:
    Leader 8103

Отправлено 22 Июль 2015 - 13:55

Ставлю Ubuntu на виртуалку, буду распаковывать epk и пытаться залить прошивку по разделам

 

Так, Ubunta не прокатила, epk2extract на ней запустить не удалось. Поставил KRD10, в нем распаковалось.
Вот ссылка на распакованную прошивку версии 5.0.3, может кому пригодится

 

Буду пробовать заливать по разделам

Прикрепленный файл  Снимок.JPG   103,31К   Количество загрузок: 0


  • 0

#7 Евгений

Евгений

    Участник

  • Участники
  • Репутация
    10
  • 34 сообщений
  • Цель регистрации:
    Поиск информации
  • Род занятий:
    студент
  • Программатор:
    Тритон, CH341A
  • Осциллограф:
    Leader 8103

Отправлено 22 Июль 2015 - 20:12

Поскольку как я понимаю, ошибки сыпались при монтировании root, перезалил root.image. Перезагрузил командой - не помогло, циклический перезапуск, лог не изменился.

 

Перезалил следующие разделы  root kern lgin mode crc3 logo estr lgap lgre lgfo - не помогло.
Перезалил mtdi и boot. Перезагрузил, перезалил все остальные - не помогло.
 
Не могу выяснить причину ошибки монтирования root... Битая нанд? Позже попробую стереть - записать заново на программаторе
 
Список команд работы с нандой в этой версии
Spoiler

  • 0

#8 Евгений

Евгений

    Участник

  • Участники
  • Репутация
    10
  • 34 сообщений
  • Цель регистрации:
    Поиск информации
  • Род занятий:
    студент
  • Программатор:
    Тритон, CH341A
  • Осциллограф:
    Leader 8103

Отправлено 22 Июль 2015 - 23:09

:excl: Может ли кто-нибудь скинуть в тему или личку лог  mtdinfo с заведомо исправного майна L*01S?  

Хочу сверить адреса со своими, не уплыли ли у меня разделы на флешке.


  • 0

#9 Евгений

Евгений

    Участник

  • Участники
  • Репутация
    10
  • 34 сообщений
  • Цель регистрации:
    Поиск информации
  • Род занятий:
    студент
  • Программатор:
    Тритон, CH341A
  • Осциллограф:
    Leader 8103

Отправлено 27 Июль 2015 - 00:37

Поставил другую флешку (чистую), стал потихоньку заливать через loadz,

в связи с чем возник вопрос: разделы boot, kernel, lgapp, lgres - дублируются.

Команда loadz [имя раздела] - заливает всегда только в первый по счёту раздел.

Пробовал переименовать второй раздел и залить по новому имени - unknown partition.

Пробовал заливать по адресу раздела - unknown partition

Прикрепленный файл  Снимок.JPG   102,32К   Количество загрузок: 0


  • 0

#10 Евгений

Евгений

    Участник

  • Участники
  • Репутация
    10
  • 34 сообщений
  • Цель регистрации:
    Поиск информации
  • Род занятий:
    студент
  • Программатор:
    Тритон, CH341A
  • Осциллограф:
    Leader 8103

Отправлено 30 Июль 2015 - 03:34

В разделах [5]boot, [20]kernel, [21]lgapp, [22]lgres содержится резервная копия предыдущей прошивки для возможности отката. Соответственно, исходя из лога mtdinfo:

Spoiler

делается вывод, что аппарат помер не при попытке неудачной перепрошивки, поскольку тогда в разделах  содержались бы данные резервной копии. А текущая версия ПО... 04.01.22:fau:Если так, то ближайшее по версии обновление с сайта LG 04.99.99   от марта 2013.


  • 0

#11 Евгений

Евгений

    Участник

  • Участники
  • Репутация
    10
  • 34 сообщений
  • Цель регистрации:
    Поиск информации
  • Род занятий:
    студент
  • Программатор:
    Тритон, CH341A
  • Осциллограф:
    Leader 8103

Отправлено 28 Август 2015 - 17:08

После поисков удалось слить дамп с нанды исправного майна L*01S. Записал в свой - получил ту же ошибку с перезагрузкой, что была у меня и до этого.  :twisted: . Таки, не в нанде дело. Хотя с моим логом дело явно не в квадратной шине, в надежде на чудо поднял с платы тюнер и NTP-7100 - чудо ожидаемо не пришло.

 

Вспомнилось по роутерам, что ошибка монтирования может возникать и из-за глюков оперативки, проверил: команда mtest вызывает зависание аппарата при тестировании первого же адреса 00000. Но подключившись по debug к исправному LG выяснил, что и в нём команда mtest вызывает аналогичное зависание.

 

В итоге: причина не установлена, дефект не устранён, впаяна родная NAND, аппарат пошёл к клиенту. Тему можно закрывать


  • 1





Темы с аналогичным тегами L*01S, NAND, Debug, 22LV2300, Перезагружается

Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей